The client is offline due to RuneScape update. You may see instance errors but this is due to the update and not actual instance errors. This should be resolved soon. Join our Discord for more information.

How to fix the client being super small


  • Director

    There have been numerous reports of the issue where the botting client is down scaled like this:

    dpi

    It's an issue with Java performing DPI scaling on high resolution devices. To fix it you need to do one of the following depending on how you start your client:

    1. Do you start your client through the launcher/jar directly?

      a) Locate your JRE folder (usually under Program files/Java)

      b) Open it and go into the bin folder (so Program Files/Java/jre1.x_xxx/bin/)

      c) Find the file called java.exe, right click it and open the properties menu

      d) Go to the compatibility tab and press the button near the bottom called "Change DPI settings"

      e) Under "High DPI scaling override" tick the checkbox and in the dropdown menu select "System (Enhanced)".

      f) Press OK on both open windows

      g) Repeat steps d -> f but instead for the file called "Javaw.exe" in your JRE folder.

    2. Do you start your RSPeer through intellij?

      Perform steps b -> g from the previous section but instead of doing this for "Java.exe" and "Javaw.exe" inside your JRE folder you need to do this for the files in your JDK folder. This folder is usually located at the same location as your JRE folder but is instead named jdk1.x_xxx


    Do you have any other questions about this topic? Feel free to leave them here! For any other questions regarding OSRS botting using RSPeer please check out the information section and if there is no resources available for your botting related question post them here.


  • Director

    You can just install Java 11 and use that and it fixes all UI issues. https://adoptopenjdk.net/



  • The very first method does apply only on Windows 10. Therefore, here is a fix for Windows 8.1 machines.

    First off, uninstall all old JRE updates and make sure current installed JRE 32- or 64-bit version matches with OS bit version. If there is a bit mismatch between JRE and OS, subsequent does not fix the problem.
    Also, be aware: Java online installer installs 32-bit JRE version on 64-bit OS, so 32-bit uninstallation and 64-bit manual download and installation is needed.

    After reading this article and implementing some parts of this, here is a fix for Windows 8.1:

    Press Windows Button + R, type “regedit”, and then click OK.
    Navigate to the following registry subkey:
    HKEY_LOCAL_MACHINE > SOFTWARE > Microsoft > Windows > CurrentVersion > SideBySide
    Right-click, select NEW > DWORD (32 bit) Value
    Type PreferExternalManifest, and then press ENTER.
    Right-click PreferExternalManifest, and then click Modify.
    Enter Value Data 1 and select Decimal.
    Click OK.
    Download the .manifest file from Runescape website.
    Rename downloaded file to java.exe.manifest
    Make a duplicate of it and rename second one javaw.exe.manifest
    Go to your JRE installation bin directory (usually C:\Program Files\Java\jre1.8.0_201\bin, RSPeer uses different directory - C:\Program Files (x86)\Common Files\Oracle\Java\javapath_target_7138406; To determine, which directory is the correct one, start the problematic application, open task manager, right click on problematic application in the list and choose option "Open file location".)
    Copy and paste both .manifest files into the bin directory like so:
    dpi
    Finally restart your Java application.

    After Upgrading Windows (e.g from win10 to win10 1607), you should apply this fix again if it doesn't work anymore.
    After Updating Java, you should copy and paste .manifest files into new Java's directory.


  • Director

    Lol you don’t need to do all that, just install java 11


 

52
Online

15.4k
Users

1.3k
Topics

18.6k
Posts