The client is offline due to RuneScape update. You may see instance errors but this is due to the update and not actual instance errors. This should be resolved soon. Join our Discord for more information.

Clients closing and extra client being ran

  • Hello, I'm having an issue with the launcher and bot management. I was running 3 instances of rspeer clients, launching from the bot management panel to the launcher that is running locally. All three just crashed showing this stacktrace:

    java.lang.ArrayIndexOutOfBoundsException: index 4 out of bounds for length 3
        at client.r (Unknown Source)
        at (Unknown Source)
        at client.hc (Unknown Source)
        at client.fn (Unknown Source)
        at (Unknown Source)
        at ah.u (Unknown Source)
        at (Unknown Source)
        at java.base/

    It then immediately closed all 3 clients. And now my bot management page is showing a client running when I have nothing running (java isn't running) on my computer with a different RSN than I've ever used. However, it also says that I have 0 instances used even though it shows this extra random client running.

    Any help with this would be appreciated as it's annoying to have my clients just crash randomly. I tried to provide as much information as I could, but let me know if there's anything else I could add that would help solve this. Thanks.

  • This post is deleted!

  • Director

    Which script were your running? BHideTanner? @Light

  • apparently some scripts do not have support for Bot Management. as is LChopper. some scripts generate errors in the launcher when they are executed with Bot Management ...

    @MadDev, Would it be possible to modify the Quick Launch Manager, so that instead of executing some scripts, it just started my account? choosing a clear world ... it would be a more secure way both for the use of multiple proxies and not wanting to damage the x.x lancher

  • Director

    @franklong The Bot Panel runs the clients the same way as quick launch, the only errors I could see is if the script does not check if the user is logged in.

  • @MadDev Yes I was running bhidetanner. The issue with the extra client shouldn't be related to the script although I admit the crashing may be.

  • Director

    @Light You said it said you had no instances running though?

  • @MadDev Yes, the bot management showed an extra client running with an RSN that I never used, or created. The instances used stayed on 0 though.

    Java was not running on my computer during this time either. It's a weird glitch, not sure what could be causing it from what I can see. I will get a screenshot of it next time it happens and post it here so you can see exactly what I'm talking about.

  • Director

    The only thing i can think of would be if someone used your link key so you saw their bot in your panel, but I'm not sure how that'd be possible unless you shared it.

  • @MadDev I've never shared it so I'm not sure how they would have gotten it. What would even be the point of someone doing that though since they aren't using one of my instances?
    Here's the screenshot by the way: Untitled.jpg

    I'll try reinstalling with a new key and see if that fixes the issue. Thanks for your help MadDev.

  • Director

    @Light That client you are seeing is from an RSPeer user named centreside12, his email starts the same was as yours does. You sure you weren't logged in on multiple accounts?

  • @MadDev I don't have any outlook accounts so that user account isn't mine. Is there any reason that it shows 0 instances and yet 1-2 outlook clients being used?

    I tried generating a new key and connecting that but the client is still showing up. Now there are 2 apparently.

  • Director

    @Light Yeah its 0 instances used because the account isn't coming from your account, I'm not sure why its showing up there, i'll have to debug later. If you kill it, what happens?

  • @MadDev The account goes away and then comes back sometime later. I'm assuming someone is launching it. I do wonder if me closing it actually closes their client. I can't see anything in the logs for this client, probably not getting logged to my instance.

  • maybe it needs to delete browsing history ๐Ÿ˜• ?