The client is offline due to RuneScape update. You may see instance errors but this is due to the update and not actual instance errors. This should be resolved soon. Join our Discord for more information.

Help! My client won't open.

  • Director

    If your client will not open, it is usually caused by a simple reason. Try the following methods to resolve this.

    1. If you a using a proxy, verify that your proxy is a correct and valid SOCKS5 proxy. HTTP Proxies will NOT work.
    2. If you have verified your proxy is valid and it is still not loading, try loading the client without the proxy.
    3. If the client still does not load without a proxy, continue to step 4 and 5. If it does load, your proxy is the issue.
    4. Delete the following folder located at HOME_DIRECTORY/RSPeer on Mac/Linux and My Documents/RSPeer on Windows.


    1. Delete the following folder located at HOME_DIRECTORY/.rspeer. It might be hidden, be sure to show hidden folders.


    Once those folders are deleted, re-run the launcher and let it re-download everything.

    If you have done all of that and it still does not work, continue to step 6.

    1. If you have tried all the methods above and it still does not work. Try uninstalling all java versions that you have and let the launcher download and install Java, or download manually.

    2. If you have attempted step 6 and it still does not work, please contact our support channel on Discord.

  • Doesn't work my client is stuck at 10% everytime I open